CalcBuilder Forum

Weird email sent text string

User TheFencepedia 2024-07-10 06:51:01

Hi,

I'm trying to set up email sending, and first of all, it's not sending, but secondly, it's giving a weird text string on the frontend. Seems like it's using the wrong part of the variable?

You can see it at the top of this screenshot.

Moonsoft support 2024-07-10 17:31:38

Hi,
the emails are sent using your default Joomla email system/configuration, we have checked the test mail seems ok, and we also received a couple of emails from the calculator, with the pdf attached, so this seems to be working as expected. Regarding the 'ok' message, that is a language string that doesn't find a proper translation, we'll include a default in the next version at our language files, but you can set any custom message there adding your own text. Go to 'language overrides' at your Joomla dahsboard, and create a new entry there, with the Language Constant

EMAIL_SENT_OK

and with your preferred text to show at the page.

Hope this helps, regards
Moonsoft Team

User TheFencepedia 2024-07-10 17:35:00

Thanks. I did notice that after a few more tries, some of the issues I was having, like email sending and the weird input text was working again.

Could this be caching? It's a bit difficult when you're making changes, you test them and at first they do nothing, and then the issue is fixed.

If it is caching, is that at the component level or somewhere else I should change something?

...
CalcBuilder

Create dynamic calculators

Buy now!
...
List Manager

Build different lists for your site

Buy now!