CalcBuilder Forum

Calculation builder not working

Usuario moon_356 2012-03-13 01:49:50

Hello
I ve installed the component and I am able to show the sample formating numbers on a certain article. However when I press the calculate nothing happens. Please can you help
I am getting this as a debug $("13283_cb_result").dissolve is not a function

the link is http://www.raptou.gr/index.php?option=com_content&view=article&id=81:-40142011&catid=46:-401411&Itemid=88&lang=el

Moonsoft support 2012-03-13 09:21:44

Hello,

We´ve take a look at your site and we realize your site use Mootools Upgrade plugin. You can try to disable and check again the page.

Calcbuilder version for joomla 1.5 use mootools 1.12 and Calcbuilder version for joomla 1.6,1.7 use mootools 1.3.
We have this correspondence because we only use joomla standard libraries, mainly due to the fact that (as you are suffering now) changing core libraries causes other components to stop working.

We'd start finding out if your other components are able to work with any of these standard configurations. If they give you no solution and force you to use mootools 1.25, the only way to make calcbuilder work is to make some code fixes to build an specific version to work with m1.2.5, changing the javascript lines that the new mootools doesn't execute to some funcions compatible.

Hope this helps. Regards,

Moonsoft Team

Usuario moon_356 2012-03-13 15:36:01

Right! Thanks very much for the quick response! Now its working but I have another problem. I wrote a simple calculator and while its running smooth in Google Chrome in Firefox it freezes the page and I get an unresponsive script error.... The example worked fine in both browsers. Can it be something with the language that I am using which is Greek?

Moonsoft support 2012-03-13 16:28:30

Hello,

Check if in Calculator preferences is filled Frontend Number format, Decimal and Thousand.
If you use number fields you must fill Decimal and Thousand fields in order to work properly.

Hope this helps. Regards,

Moonsoft Team

Usuario moon_356 2012-03-13 16:46:51

Ok that worked also. I have forgotten to assign a thousands sign and now is working. And one final question...! Only in Firefox the listbox text background color is black and the user cannot see the options until the mouse is hovered on top the selection.. Is there any solution around it?

Moonsoft support 2012-03-13 17:02:52

Hello,

To make some visual features on Calcbuilder you should change:

Joomla/modules/mod_calcbuilder/assets/css/default.css

In your case, take a look at this css classes:

.cb_form .inputbox
.cb_form .inputbox:focus

and delete or comment background property.

Regards,

Moonsoft Team

...
List Manager

Build different lists for your site

Buy now!
...
Support/development

Perfect for small code changes or to correct any bug at your site

Buy now!