CalcBuilder Forum

Parse Error

User moon_1000 2013-04-04 14:53:53

Hey guys

I have recently started using Calc Builder and noticed whenever i click on the Calculate button at the bottom i get a Parse Error.

"Parse error: syntax error, unexpected '=', expecting T_VARIABLE or '$' in public_html/******/components/com_calcbuilder/models/calcbuilder.php(400) : eval()'d code on line 1

What can be causing this and what is the way around it?

Thanks for your time.

User moon_1000 2013-04-04 15:26:08

Also i have just started getting this error.

Fatal error: Unsupported operand types in /public_html/******/components/com_calcbuilder/models/calcbuilder.php(377) : eval()'d code on line 1

Again any help fixing it would be great.

Moonsoft support 2013-04-04 17:39:41

Hello,
these errors may be caused for any expression you have written at the code section with a wrong sintax. You may have added any variable without the $ sign, or maybe one of your lines doesn't end with ; , you may have missmatched parentheses...we suggest to double-check your math expressions, maybe you can comment /* */ sections of your code to help you find where is the wrong expression located.

If you can't figure out which is the problem, please open a ticket at the helpdesk and paste your code there, we could take a look and let you know which could be the problem.

Thanks, regards

...
Support/development

Perfect for small code changes or to correct any bug at your site

Buy now!
...
CalcBuilder

Create dynamic calculators

Buy now!