Forum


List Manager Support

List Manager support
Forums
Public write access is disabled. Please login

Frontend list sort broken? 08.11.2014 11:47

Hello,

I have successfully setup my list along with some views.
Everything works fine except for one thing: Sorting / Sort fields.

When I Access the Configuration->Frontend Configuration form I can see the Button "Default List sort" (or in my case: "Standard Liste sortiert nach").
However, when I click the button, nothing happens. There is no blank field where I can select the sorting field.

This is strange enough, but I also observe the following behaviour in the "Frontend Configuration" tab: When I select "Show Form in Modal Box" = Yes or "Show Detail on row click" and I hit the save button it says: "List saved". When I go back to the same Dialog the two Settings are back to "No".

Somehow I have the Feeling that my LM Installation is broken. I am using the latest release (2.0.8) on Joomla 3.3.6. I had to do a Manual install as described in the Manual, after the normal install via upload didnt work.
I just reinstalled the component (unzip, upload to temp dir and Install from dir), I got a success message.

Everything else seems to work fine, except for sorting. Even when I define sorting in a view this does not Show the desired behaviour (I could describe this in more Detail but maybe this is only a symptom of the underlying Installation problem.

Any tips apreciated.

Thank you very much
Arnd

Re: Frontend list sort broken? 08.11.2014 14:04

Additional Info:

When I use the debugging console in Firefox I get the following two errors when I click the List Standard Sort->Add-Button:

(Translated from German into English, so the exact phrase in an English installation might be different):

Empty String handed over to getElementById() / jquery.min.js:2
Empty String handed over to getElementById() / jquery-1.9.0.js:5

When I load the Configuration page I get the following error:

TypeError: $(...).getElement(...) is null index.php:554

What I have (unsuccessfully) tried so far:
- temporarily disable .htaccess
- Switched back to php 5.5 from 5.6
- made sure no jquery plugin is active
- mootols is not blocked / diabled

I am not sure if this information is helpful.

Thanks
Arnd

Edited by moon_1851 - 08.11.2014 14:34

Re: Frontend list sort broken? 10.11.2014 10:30

Hello,

We thisnk this is not related with installation. Seems that there's any plugin in your backend throwing a javascript error. You can check/disable if you have any backend plugin or, if you want, go to Customer Area and place a ticket with credential of your site and we'll take a look.

Regards,
Moonsoft Team
www.moonsoft.es

Re: Frontend list sort broken? 10.11.2014 21:58

Thank you for your kind offer!
I have disabled the two listed backend plugins but that didn´t help.
I have also disabled other plugins just in case but this had no effect either.
So I´ll get back to your offer of having a look...

Arnd
Are you satisfied with our products/services/support?
Please help us to keep improving, add a review at  joomla extensions site and  magento connect
FaLang translation system by Faboba

Our clients' feedback