Forum


Calc Builder Support

Calc Builder support
Forums
Public write access is disabled. Please login

Image(s) not showing in Exported PDF 07.02.2018 07:15

I'm having an issue with images not showing up on my exported PDF. I was using an older version of Calc Builder and it was working then. I only just updated today to 3.3.9 (Before I was using 2.1.7). I've tried a lot of different things and I'm at a loss as to how to fix the problem or even where to look for the problem. The image shows up in emails, just not on the PDF document.

Here is a link to the calculator in questions. xxxxxxxxxxxxxxxxxxxxxxx
Any ideas?

Edited by moon_1053 - 07.02.2018 07:16

Edited by moon_1053 - 09.02.2018 02:10

Re: Image(s) not showing in Exported PDF 07.02.2018 09:15

Hi,
the pdf generation has not changed between those versions, we can think in any difference in the way the images are included at the html. Please double check if you can see any difference between the images at the email section and the pdf one, using the editor code view, so you can check if you are using absolute paths for the images (src="http://qualitypitliners.com/...." ), or relative ones (src="/images/..."). The pdf can only work if you use absolute path so they can be included inside the document.

Please let us know if this helps.

Thanks, regards
Moonsoft Team
www.moonsoft.es

Re: Image(s) not showing in Exported PDF 08.02.2018 00:18

I installed a backup I made yesterday to see if the PDF was exporting with the image. It was and currently is.

But now I can't update the Calc Builder and it seems broken, if I make any changes and save, it clears all the data fields and then saves that. When I try to update the Calc Builder, it tells me:
---------------------------
Warning
Duplicate column name 'mail_subject'
Package Update: There was an error installing an extension: com_calcbuilder.zip
×
Error
Error installing package
----------------------------

I'm going to keep working on it but I don't know a ton about how all this works, just trying different things and googling solutions.

Re: Image(s) not showing in Exported PDF 08.02.2018 00:55

OK, I think I got it all working now. I reinstalled the backup file. I uninstalled the old calc builder. I reinstalled the latest calc builder version. Imported my calculator. Everything seems to be working now. ::knock on wood:: ...and also the image is now loading on the PDF too! So I think I'm good.

EDIT: Figured something out. I changed the PHP version to 7 and the images went away on the exported PDF. When I switch PHP version back to 5.6, the images show up again. So I think it's related to that. Tried PHP 7.1 and PHP 7.2, images didn't show up with either one of those versions either.

Edited by moon_1053 - 08.02.2018 01:15

Re: Image(s) not showing in Exported PDF 08.02.2018 12:25

Hi,

About images in php7, please ensure php7 load gd extensions (also mbstring needed). This is a requirement for pdf library to display images.

Thanks. Regards,

Moonsoft Team
Moonsoft Team
www.moonsoft.es
Are you satisfied with our products/services/support?
Please help us to keep improving, add a review at  joomla extensions site and  magento connect
FaLang translation system by Faboba

Our clients' feedback